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II. CILJ PRIPRAVE 3D MODELOV 
 
 
 
 
 
 
 
__________________________________________________________________________ 
 
Urbani sistem kot je Mestna občina Ljubljana zahteva učinkovit sistem preverjanja 
vključevanja urbanističnih projektov v 3-dimenzionalni prostor. Vsebinsko mora ta pristop 
vključevati tako dolgoročne strateške usmeritve, sprejete izvedbene akte kot tudi formalne ali 
neformalne urbanistične preveritve. Posebej pomembno je sistem preverjanja vključevanja 
urbanističnih projektov v 3D prostor stalna aktivnost, ki je integrirana v postopke priprave 
strokovnih podlag urbanističnih projektov in njihovega sprejemanja. Pri izvedbi naloge je 
potrebno uporabiti tehnološki platformi Google Earth in ESRI za 3D vizualizacijo in 3D 
prostorske informacijske sisteme, ki so v uporabi na Mestni občini Ljubljana-Oddelek za 
urejanje prostora.  
 
ob sprejemanju novih prostorskih načrtov Mestne občine Ljubljana kompaktno predstaviti 
dolgročne 3D oblike mesta Ljubljane, posamezne 3D urbanistične preveritve in 3D oblike že 
sprejetih podrobnih prostorskih izvedbenih aktov. 
vse pripravljene 3D oblike sistematično vključiti v podatkovno bazo 3D modelov Mestne 
občine Ljubljana 
 
  



III. OSNOVNA STRUKTURA 3D MODELA 
 
 
 
 
 
 
 
__________________________________________________________________________ 
 

OBJEKTI 
- pregleden 3D model (poševne 

strehe, v skrajnem primeru samo 
kubusi) 

- načrtovana fasada 
(poenostavljeno), če fasada še ni 
določena, se uporabijo barve 
določene z tehničnimi pravili 
(stanovanjska raba, 
nestanovanjska raba, mešana 
raba)  

PODLAGA 
- osnovna struktura rabe površin 

(promet, zelene,...) na terenu 

- drevesa simbolično isti element 
(3D) 



Predlog barv za načrtovane projekte, ki še nimajo določene fasade 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



IV.  VKLJUČEVANJE V POSTOPEK PRIPRAVE IN SPREJEMANJA  
      OBČINSKEGA PODROBNEGA PROSTORSKEGA NAČRTA 
 
 
 
 
 
 
 
__________________________________________________________________________ 
 
 
 

Faza priprave OPPN 3D model 
 

Sklep o pričetku OPPN  
 

 

Priprava pogodbenih obveznosti                                           - vključevanje dodatnih obveznosti za 3D 
modele, 

- seznanitev z Tehničnimi pravili 

Predaja delovnega dopolnjenega osnutka 
 

- predaja 3D modela- delovni osnutek 
- preveritev skladnosti 3D modela z 

Tehničnimi pravili 
- prenos na portal 3D Urbanizem MOL 

(interno) 

Predaja dopolnjenega osnutka za Mestni 
svet 
 

- predaja 3D modela - osnutek za Mestni 
svet 

- preveritev skladnosti vsebine in oblike 3D 
modela z Tehničnimi pravili 

- prenos na portal 3D Urbanizem MOL 
(interno ali Mestni svet ali javno) 

Predaja doplnjenega osnutka za javno 
razgrnitev 
 
 

- predaja 3D modela - osnutek za javno 
razgnitev 

- preveritev skladnosti vsebine in oblike 3D 
modela z Tehničnimi pravili 

- prenos na portal 3D Urbanizem MOL 
(javno) 

- objava z drugim gradivom in zbiranje 
pripomb 

Predaja predloga za Mestni svet - predaja 3D modela - predlog za Mestni 
svet 

- preveritev skladnosti vsebine in oblike 3D 
modela z Tehničnimi pravili 

- prenos na portal 3D Urbanizem MOL 
(interno ali Mestni svet ali javno) 

Predaja sprejetega akta 
 

- predaja 3D modela - sprejeti akt 
- preveritev skladnosti vsebine in oblike 3D 

modela z Tehničnimi pravili 
- prenos na portal 3D Urbanizem MOL 

(javno) 
 

 
 
 



 

V.  TEHNIČNA OBLIKA 3D MODELA IN PRAKTIČNI PRIMERI*  
 
 
 
 
 
 
 
__________________________________________________________________________ 

OSNOVNA PRIPRAVA 

1. Osnovna orodja 

Za pripravo 3D modela zazidave je na računalnik potrebno namestiti dve (brezplačni) 
aplikaciji: 

Google SketchUp 7.1 za izdelavo 3D modela (Windows in Mac OS X) – 
http://sketchup.google.com/support/bin/answer.py?hl=en&answer=60107  

ali Google SketchUp 8 – http://sketchup.google.com/download/ (zaradi kasneje opisanih 
omejitev nove verzije priporočamo uporabo starejše verzije) 

Google Earth (Windows, Mac OS X in Linux)  http://earth.google.com/download-
earth.html 

Poleg tega je, vkolikor želite izdelati tudi teksture za podlogo ali fasade, potreben tudi 
kateri od programov za obdelavo vektorskih ali rastrskih slik, ki omogoča izvoz datotek v .png 
formatu (npr. Adobe Illustrator, Corel Draw, Adobe Photoshop, odprtokodni Gimp, ...) 

2. Priprava SketchUp okolja 

1. Ker SketchUp kot mersko enoto privzeto uporablja palce, je najprej potrebno 
poskrbeti za nastavitev metričnih enot. V kolikor ob prvem zagonu SketchUp-a nismo 
izbrali osnovne nastavitve (template) z metričnimi enotami, jo lahko izberemo 
naknadno preko menija Help > Welcome To SketchUp... > Choose Template, kjer 
izberemo Google Earth Modeling – Meters. 

 

                                                 
*
 Pripravil: Jernej Vidmar, mag.inž.arh. 



 
 



2. Poleg tega je metrične enote možno zamenjati tudi preko menija Window > Model 
Info > Units, kjer izberemo Format: Decimal, Meters. 

 

 
 

 

3. Izdelava volumna stavbe 

1. S pomočjo Rectangle Tool-a narišemo tloris stavbe. Dimenzije lahko določimo preko 
Value Control Box-a tako, da vpišemo dimenzije v X in Y smeri, ločeni s podčrtajem in 
pritisnemo tipko Enter. 

2. Če imamo bolj zahtevno obliko stavbe, lahko njen tloris narišemo na dva načina: 
bodisi s pomočjo Line Tool ali z večkratno uporabo Rectangle Tool-a, kjer poskrbimo, 
da se posamezne ploskve stikajo. 

 

 



3. Ko je tloris stavbe enkrat narisan, mu dodamo tretjo dimenzijo. To je najlažje narediti 
z uporabo ordja Pushpull, kjer višino prav tako lahko vnesemo preko Value Control 
Boxa. Če stavbi želimo dodati tudi etaže, med posameznimi izvedbami pushpull 
operacijami pritisnemo tipko Ctrl. 
 

 
 

4. Narejeni stavbi izbrišemo dno, ki v Google Earth-u ne bo vidno. To naredimo 
preprosto tako, da z orodjem Select izberemo spodnje lice in pritisnemo tipko Delete. 
Izbrišemo tudi ostale morebitne nepotrebne robove in lica. 
 

 

 

 



4. Označevanje stavbe 

1. Volumnu stavbe je potrebno dodati tudi material, ki označuje osnovno namensko 
rabo. Ta je lahko stanovanjska, nestanovanjska ali mešana. Vsi potrebni materiali so 
priloženi delovnemu gradivu in se nahajajo v mapi \Datoteke\Materiali_in_drevje\. 
Naložimo jih tako, da odpremo Window > Materials in izberemo Open or create a 
collection... na desni strani okna, ki se odpre. 
 

 
 

2. Ko so materiali naloženi, izberemo vsa lica stavbe s troklikom (orodje Select), nato 
izberemo material. Kurzor se spremeni v vedro, s katerim sedaj kliknemo na izbrano 
stavbo, katera se sedaj obarva z izbranim materialom. 
 

 

 

 



3. Če že pripravljenih materialov nimamo jih lahko v SketchUp-u naredimo sami. Njihove 
RGB vrednosti so sledeče: 

◦ Stanovanjska raba – 242, 232, 181 

◦ Nestanovanjska raba – 205, 224, 242 

◦ Mešana raba – 211, 229, 201 

◦ Obstoječa zazidava – 216, 214, 210 + transparenca 90% 

◦ Robovi – 127, 127, 127 

◦  

5. Priprava v Google Earth-u 

1. Po zagonu programa Google Earh se premaknemo na območje projekta. Najhitreje 
je, če v vpisno polje Fly To vpišemo Ljubljana, nato pa s pomočjo miške določimo 
natančnejšo lokacijo (Scroll – približevanje/oddaljevanje in levi miškin gumb 
premikanje). Lahko pa se poslužimo tudi navigacijskih orodij v desnem zgornjem 
kotu. 
 

 

 

 

 

 

 

 

 

 

 

 

 



 

2. V kolikor imamo pripravljeno podlogo območja zazidave, je sedaj čas, da jo 
pozicioniramo v Google Earth. To storimo preko gumba Add Image Overlay (v orodni 
vrstici), ki nam odpre okno za izbiro pripravljene .png datoteke (s transparenco!). Ko 
je datoteka naložena, jo natančneje pozicioniramo.  

 

3. Ko je podloga območja umeščena jo shranimo za kasnejše delo. To storimo tako, da 
jo v panelu Places najprej smiselno preimenujemo in nato z desnim klikom nanjo 
(prav tako v Places meniju) izberemo opcijo Save Place as..., ki nam odpre okno za 
shranjevanje .kmz datoteke, ki jo nato shranimo. 

 

4. Nato se vrnemo v SketchUp. Pri tem moramo biti pazljivi, da je v Google Earth 
vključen 3D teren in da imamo nastavljen navpičen (tlorisen) pogled. 

Opomba: v kolikor delamo v SketchUp verzijo 8, uvoz terena iz Google Earth-a ni 
omogočen, saj SketchUp 8 teren uvozi neposredno iz aplikacije Google Maps (File > Geo-
location > Add Location...), kjer pa zaenkrat ne moremo dodajati lastnih podlog. Sicer pa je 



prednost novega sistema natančnejši 3D teren in ortofoto posnetek v barvah. 

6. Geolociranje zazidave 

1. Uvažanje Google Earth terena v SketchUp poteka preko ukaza Tools > Google Earth 
> Get Current View, pri čimer SketchUp poskrbi, da se trenutni pogled v Google 
Earth-u prenese v 3D model, na katerem delamo. Ker je v osnovi prikazan teren 
raven, potrebujemo pa 3D relief tega vklopimo preko Tools > Google Earth > Toggle 
terrain. 

 

 

2. Ko smo preklopili na 3D teren, prej narejen volumen stavbe premaknemo na pravilno 
pozicijo s pomočjo Move/Copy orodja in po potrebi zasukamo (orodje Rotate). Pri tem 
moramo biti posebej pozorni na višinsko koto spodnjega roba stavbe, da le-ta ni v 
zraku ali pregloboko potopljena. 
 

 



 

 

3. Vkolikor je v okolici nove zazidave predvidena tudi zasaditev dreves, te dodamo kot 
komponente. Drevo kot komponento naložimo iz iste mape kot materiale 
(\Datoteke\Materiali_in_drevje\) preko okna Window > Components, kjer izberemo 
Open or create local collection, ki naloži komponento drevo_png. Kopije tega drevesa 
sedaj razporedimo glede na parkovno ureditev s pomočjo orodja za premikanje 
(Move) oz. ga kopiramo s pritiskom na tipko Ctrl. 
 

 

 

Za konec nastavimo približen pogled na objekt kot želimo, da se prikaže uporabnikom 
Google Earth-a, ko bodo izbrali stavbo. Za predogled zazidave v Google Earth-u 

sedaj kliknemo na Tools > Google Earth > Place Model. 
 

 



 

7. Priprava končne .kmz datoteke 

4. Če pogled v SketchUp-u ni popolnoma usklajen s tistim v Google Earth-u, poskrbimo 
še za njegovo ponastavitev. Najprej torej popravimo pogled v Google Earth-u, kjer v 
panelu Places izberemo pravkar uvoženi model. Z desnim klikom na SUPreview() 
odpremo meni Properties. Model najprej preimenujemo, nato pa odpremo zavihek 
View in kliknemo na gumb Snapshot current view, s čimer določimo novo lokacijo 
pogleda. 
 

 

 

Če smo predhodno pripravili tudi podlogo projekta to sedaj v meniju Places 
povlečemo v novi 3D model. 

 

 



 
 

5. Model je sedaj pripravljen na izvoz v končno .kmz datoteko. To naredimo tako, da 
zopet v meniju Places z desnim klikom na objekt izberemo Save Place As..., ki nam 
odpre okno za shranjevanje, v katerem določimo kam naj se končna .kmz datoteka 
shrani. 
 

 

 

 

NAPREDNEJŠA PRIPRAVA IN KORISTNE INFORMACIJE 

1. Uvoz dwg/dxf datotek 

Ker brezplačna verzija SketchUp-a od verzije 7 naprej ne podpira uvoza .dwg in .dxf je 
potrebno najprej prenesti vtičnik za uvažanje omenjenih datotek v SketchUp 7.1. Ta je 
dosegljiv preko spletnega naslova: 
http://sketchup.google.com/intl/en/download/plugins.html#dwg ali na priloženem gradivu v 
mapi \Datoteke\SketchUp_7.1_dwg_import\. Omenjeni vtičnik za SketchUp 8.0 ne obstaja. 

Pri uvozu .dwg in .dxf datotek je potrebno vedeti, da vtičnik omogoča le uvažanje črt (lines, 
polylines), medtem ko polnil (hashes) ne podpira. Poleg tega prenese tudi plasti (layers). 
Zato je ob morebitni pripravi .dwg/.dxf datoteke za uvoz v SketchUp vse nepotrebne 
elemente v čim večji meri odstraniti. 

2. Uvoz že narejenih 3D stavb v SketchUp 

Če je 3D model zazidave že pripravljen v katerem drugem programu (npr. 3DS Max, Maya, 
Cinema 4D, …) je model možno uvoziti v SketchUp. Najprimernejši format, če ga program v 
katerem je 3D model izdelan, je Collada (.dae), sicer pa je omogočen tudi uvoz .3ds datotek. 

Ker tako uvožena geometrija stavbe praviloma vsebuje bistveno več podatkov kot je 
potrebno, je model potrebno optimizirati (glej PRIPOROČILA ZA IZDELAVO IN 
OPTIMIZACIJO 3D MODELOV, odsek OPTIMIZACIJA MODELA V SKETCHUP-U ), morda 
pa je celo bolje da se ga naredi na novo. V tem primeru je uvoženi 3D model vseeno dobra 
osnova za določitev osnovnih gabaritov. 



3. Izdelava stavb z vidnimi etažami 

Stavbe, izdelane s pomočjo SketchUp-a v Google Earth-u privzeto nimajo vidnih robov. 
Posledično to pomeni, da etaže objektov niso vidne. Če kljub temu želimo, da se etaže vidijo, 
to storimo po naslednjem postopku (predvidevamo, da ima stavba dodane etaže): 

1. Najprej skrijemo robove preko View > Edge Style > Display Edges. 
 

 

 

2. Nato z izbranim orodjem Select izberemo celo stavbo. 
 

 

 

 
 



3. Zatem ponovno prikažemo robove (View > Edge Style > Display Edges), pritisnemo 
Shift in še enkrat izberemo (obkrožimo) celo stavbo. Sedaj so izbrani samo robovi. 
 

 

 

Preklopimo na orodje za premikanje (Move), pritisnemo tipko Ctrl in premaknemo 
robove, da se nikjer ne stikajo s preostalim modelom. 

 

 

 

 

 

 

 



4. Robove sedaj postavimo v novo skupino (Group) tako, da gremo nad enega izmed 
njih, kliknemo na desni miškin gumb in v prikazanem meniju izberemo Create Group. 
S tem poskrbimo, da se robovi ne bodo 'zlepili' s preostalim 3D modelom. 

5. Sedaj počistimo vsa lica, ki se v Google Earthu ne bodo videla (notranje etaže). To je 
najlaže naredimo tako, da posamezne etaže obkrožimo z leve proti desni (izbiranje 
samo tistih entitet, ki so bile v celoti obkrožene) in jih izbrišemo s pomočjo tipke 
Delete. Ko je stavba optimizirana z orodjem Move prestavimo nazaj še skupino robov. 
 

 

 

6. Ko smo model optimizirali, povlečemo nazaj prej pripravljene robove (obarvani z 
materialom robovi) in ga izvozimo v Google Earth. 

 

 



4. Dodajanje tekstur na stavbe 

Kadar imajo stavbe ki jih pripravljamo za Google Earth že izrisane fasade, lahko te kot 
teksture nalepimo na osnovno geometrijo, kar je bistveno boljša rešitev kot modeliranje 
detajlov (hitrejši prikaz v Google Earth-u, lažje kasnejše popravljanje/posodabljanje stavb). 
Postopek nanašanja tekstur je sledeč: 

1. Najprej pripravimo teksturo, ki jo bomo na stavbo nalepili. Ta mora biti vnaprej 
optimizirana, da je njena velikost čim manjša, saj je SketchUp ob izvozu v .kmz ne 
spreminja. Priporočljivi formati so: .jpg, .png ali .gif (odvisno od števila barv). 

2. Ko imamo teksture za vse stranice stavbe pripravljene v SketchUp-u naredimo 
materiale. Izberemo Window > Materials in kliknemo na ikono Create Material... 
Odkljukamo Use texture image in določimo teksturo. 

 

3. Sedaj poskrbimo, da se velikost teksture v materialu ujema z velikostjo 3D modela 
stavbe oz. njene stranice, na katero bo tekstura projicirana z vpisom višine in/ali 
širine. Ustvarjanje materiala zaključimo s klikom na gumb OK. 

 



 

 

4. Ko je material pripravljen, ga izberemo v oknu Materials (zavihek Select) in nato 
kliknemo na lice stavbe kateremu želimo teksturo dodati. 
 

 

 

5. Kot lahko vidimo, je tekstura na lice sicer projicirana pravilno (pravokotno), vendar ni 
na pravi poziciji. To popravimo tako, da nad licem s teksturo kliknemo z desnim 
miškinim gumbom in v meniju ki se odpre izberemo Texture > Position. Nad licem se 
sedaj prikaže transparentna projekcija teksture, ki jo lahko premikamo po fasadi in 
tako določimo njeno lokacijo. 
 

 
 



6. Postopek ponovimo za vse stranice objekta, za katere imamo pripravljene fasade in 
model izvozimo v Google Earth. 
 

 

 

 

 

 

5. Koristne povezave 

1. Za lažje delo v SketchUp-u obstaja vrsta brezplačnih ali plačljivih vtičnikov (plugins), 
ki jih je možno prenesti preko spleta: 

◦ http://sketchup.google.com/intl/en/download/plugins.html 

◦ http://www.smustard.com/ 

◦ http://rhin.crai.archi.fr/RubyLibraryDepot/index.php 

◦ http://forums.sketchucation.com/viewforum.php?f=323 

2. Poleg tega na spletu obstaja tudi veliko vodičev o uporabi same aplikacije Google 
SketchUp: 

◦ http://sketchup.google.com/training/videos.html 

◦ http://www.go-2-school.com/ 

◦ http://sketchupdate.blogspot.com/search/label/Modeling%20for%20Google%20Ea
rth 

◦ http://www.youtube.com/user/SketchUpVideo 

 

 

       Vprašanja? -> jernej.vidmar@urbs.si  


